Page 1 of 1

Cannot load save

Posted: Mon Jan 02, 2017 3:25 pm
by Semivir
First I would like to say I love this mod, nothing has been able to itch that scratch fallout 2 left me with like this mod has. Thanks to the team! and for doing this for free as well just shows how that you guys must be fans aswell.

However, I can no longer load a saved game which crashed during saving, I was only using one slot so I would have to start over :(
I'm hoping someone can help me recover the save.
I have uploaded my save folder to file dropper, is this enough or do I need to do something else?

Re: Cannot load save

Posted: Mon Jan 02, 2017 6:32 pm
by Daemon
I don't know what can be done with this :( sav files are renamed to bak files, but some files are incorrect as well so just renaming them doesn't help. I haven't encouter problem like this before.
What exactly did happen during saving? What operation system do you have?

Re: Cannot load save

Posted: Mon Jan 02, 2017 8:44 pm
by Semivir
I'm using windows 7 ultimate, service pack 1, 64bit.
I walked down to alburqeuqeu, talked to the guy at the gate and sold some stuff to the trader in the same area.
I then saved over the same slot as always and the game crashed while saving. Game screen disappeared and windows told me the program must be closed.
When I restarted the game it tells me the saved game can't be loaded.

But if the files are corrupted I guess there is no way to recover it?

Re: Cannot load save

Posted: Tue Jan 03, 2017 5:39 pm
by Daemon
I have tried to recover it, but nothing works. I'm afraid there's no way to recover it, at least I don't know any.

Re: Cannot load save

Posted: Wed Jan 04, 2017 1:32 am
by NovaRain
I'm not really sure how you messed up your save like this (all files got renamed to .bak)
Good news is there's still a working copy of save.dat (save.bak, the save.dat with smaller file size is corrupted). I manage to recover your save game: (tested in a fresh installed Resurrection)
The working copy was your character in a random encounter fighting some ghouls, so I killed them all and re-save the game. Reverting back some progress is better than starting all over I guess.

And please do not use only one save slot and keep overwriting it. Fallout engine isn't the most stable one. You're just lucky this time.

Re: Cannot load save

Posted: Wed Jan 04, 2017 4:48 pm
by Semivir
Wow, thanks Novarain I was afraid it was lost forever. This was actually saved right before I entered albuqueuqeu.

However I now have the problem that entering albuqueuqe and saving will crash the game. It tells me that "the instruction at 00489467 referenced memory at 00000004 the memory could not read from"
Entering the city and leaving causes the same problem. If I don't enter the city I can save/load as normal.

FIXED IT: I walked back up to sedit (doing this in the wilderness did not work), saved then loaded. Now it seems to be working again.

Thanks guys for all the help, now I can return to exploring game.
And I will definitely start using more save slots now ;)

Re: Cannot load save

Posted: Wed Mar 01, 2017 7:10 pm
by Michoko

I'm loving this game mod, and I played until I came to [spoilers] the mission to escort a caravan to Albuquerque. So I talked to the guard [/spoilers] and tried to save the game just after that.
Then the game crashed in the exact same circumstances as Semivir. And now I can't seem to recuperate my save :evil: so i'm wondering how did you, NovaRain, managed to recuperate a save older in the same slot ?
If you can help me with this situation as you did with him, I just uploaded my "SAVEGAME" folder with my 3 slots. The "corrupted" slot is the SLOT01.
The other two are very old saves and I wouldn't want to restart from these saves as I don't really have a lot of time these days :cry:

Re: Cannot load save

Posted: Thu Mar 02, 2017 2:08 pm
by NovaRain
Just delete save.dat, rename save.bak to save.dat, then rename all other *.bak to *.sav.

Re: Cannot load save

Posted: Thu Mar 02, 2017 4:16 pm
by Michoko
Well, thank you a lot ! :D

With your method I recuperated my save just before entering Albuquerque, which is in a fight scene from escorting a caravan. So the only way out brings me automatically to Albuquerque.
So there is no way for me to go in any other place :?

When entering the city I tried to:
- save (failed)
- load a previous save (failed also)
- exit by the red exit (failed also)
- exit by any green exit (failed also)
- quit the game (also failed ! :mrgreen: )

What could I do to try to keep on playing ? do you think a reinstall of F2 and F1.5 mod would resolve the problem ?

Thanks in advance for your reply.

EDIT: it seems when trying to get out of albuquerque (by any means) there is no way to do it without crashing the game.

Re: Cannot load save

Posted: Thu Mar 02, 2017 6:30 pm
by Daemon
Strange, it works for me. Try this -
SLOT50 - I just did what NovaRain wrote.
SLOT51 - I have entered Albuquerque and saved after that.

Let me know if one of these work for you.

Re: Cannot load save

Posted: Fri Mar 03, 2017 11:11 am
by Michoko
It works !!! I don't understand how you did it but it works ! :mrgreen: :mrgreen:

Thank you both a lot ! I was afraid of losing my past 5-10 hours of gaming :cry: