BUGS Swarming our position! Request suppressing fire

What do you think about the game? Share your experiences. You can ask other players for advice about quests, or report bugs here as well. POSSIBLE SPOILERS!

Moderators: Ratman, Seto, Saruman, feťák8, valcik, NovaRain

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Mon May 28, 2018 10:37 pm

Daemon wrote:Did you in any point change NumPathNodes setting in f2_res.ini? Values 5 or higher could cause bugs like that.
I've checked. NumPathNodes is on 1.
I also never changed anything, or added anything else (patch/mods etc.). I have a default installation on top of FO2 RP Mod. This is also the second PC, my first one died on me, and both were a normal installation, without any changes made. And both had the same behaviour.
However, I really like the option to run away (I mean why not?). This quest is more about confirming Frederyk's suspicions. Killing Nicol's men or acting openly against her is not necessary (nor does it ever happen (at least with Frederyk)). I think, it is enough to report back and tell Frederyk that it was indeed a trap.
“So karma 0...perhaps?” :wink:

Daemon wrote:First of the three options depends on your charisma.For “please help” option you need decent charisma, for “offering a reward” option you need decent intelligence.
I didn't realize the stats requirements. Thanks, that helps.
But I assume you mean that the options are unlocked by (CH, IN or speech) but then need 91% speech to succeed. Is that correct?
At least I tested it again and it seems as if:

“What are you doing...” always an available option, but needs CH6+ to succeed
“One patient...” needs speech 71% to be offered and succeed
“I heard...” needs to unlock the Vodka dialogue (Penep, Richie, Challenge) and then IN (8 works, 6 doesn't) to be offered and succeed

Any of those three options then leads to the following two options:

“Please help me...” needs speech 71% to be offered and 91% speech to succeed
“Listen I'm willing to reward you...” needs speech 71% to be offered and 91% speech to succeed
(I also tried 81% speech with CH 10 and IN 10 (mentats), and it fails in both cases.)

It was those last two I referred to. And I thought it could be 91% (“Help”) (71% to be offered and 91% speech to succeed) or an offer of 2000 caps (“reward”) (2000 caps to be offered and succeed) instead.

The reason is I consider the Blaster fight a bit of a dead end, as I see little options to beat him. One can do it oneself, there are ways, but if not able to (weak character) the only other options are Gabriel (evil) or Keri (91% speech). And it seems as if the options narrow down so much that it almost feels like a dead end (or speech option only), which is unusual for the mod (normally there are more alternatives).
Or am I missing something? As said I tried a few things (killing the keeper with Dynamite (which is possible), and opening the cell and letting Blaster out, but neither seems to have an effect. As far as I can tell).

Note on waiting
I read the comment by Keri, which reminded me of two scenarios were waiting wasn't optimal:
First, waiting for the reply to Adams letter in Rat Hole. I'm never sure what to do with those 24 hours, other than taking a stroll through the waste. It's OK, but it feels a bit like slowing down the game as there is nothing else to do but waiting (i.e. I can play through the whole of Rat Hole and he's still not done writing (?!, :wink:)). Perhaps reduce it to a few hours only. Not much of a difference, but it could be nice if he is done when one has finished waiting for Katrin's purchase (i.e. a couple of hours only (instead 24) which may help to speed the game up a bit).
The second one is more annoying: Waiting for Chris to finish the Gauss Rifle. The only option is the book, but without it one has to leave the base (2 elevator rides out and 2 back in, which is annoying) only to pass time by walking around the desert (24 hours I think). Which is not optimal, and perhaps adding a “[wait until he's finished]” option in Chris' dialogue (similar to the gravedigger in Corath) could make sense.
I think both could help, but especially the Chris one could be considered.
Otherwise I don't mind taking the stroll or reading a few books (or use Waiting for Love) to pass the time. It's a bit running back and forth sometimes (ring-basement-ring-basement), but usually the routes are short enough to be acceptable.

User avatar
Posts: 259
Joined: Mon Oct 07, 2013 2:50 am

Re: BUGS Swarming our position! Request suppressing fire

Post by feťák8 » Sun Jun 03, 2018 10:48 am

Muttie wrote:Note on waiting
I read the comment by Keri, which reminded me of two scenarios were waiting wasn't optimal:
First, waiting for the reply to Adams letter in Rat Hole. I'm never sure what to do with those 24 hours, other than taking a stroll through the waste. It's OK, but it feels a bit like slowing down the game as there is nothing else to do but waiting (i.e. I can play through the whole of Rat Hole and he's still not done writing (?!, :wink:)). Perhaps reduce it to a few hours only. Not much of a difference, but it could be nice if he is done when one has finished waiting for Katrin's purchase (i.e. a couple of hours only (instead 24) which may help to speed the game up a bit).
The second one is more annoying: Waiting for Chris to finish the Gauss Rifle. The only option is the book, but without it one has to leave the base (2 elevator rides out and 2 back in, which is annoying) only to pass time by walking around the desert (24 hours I think). Which is not optimal, and perhaps adding a “[wait until he's finished]” option in Chris' dialogue (similar to the gravedigger in Corath) could make sense.
I think both could help, but especially the Chris one could be considered.
Otherwise I don't mind taking the stroll or reading a few books (or use Waiting for Love) to pass the time. It's a bit running back and forth sometimes (ring-basement-ring-basement), but usually the routes are short enough to be acceptable.
Maybe I can offer a solution. Just try to heal your companions or other NPCs 24 times (skill Doctor) or 48 times (First Aid). Better solution, of course, is healing this NPC which is not wounded because your charakter would get tired.
It works regardless of your % in both skills.
I used this solution when my character was on drugs and Gabirel/Lystra/Keri were angry with me.
But I agree with you. Maybe the time in Rath Hole could be lowered.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Sun Jun 03, 2018 11:22 pm

That's another option :). Although perhaps rather an emergency solution as “pressing the heal button” 24 or 48 times is quite a lot actually.
Reading “Waiting for Love” 12 times (with IN 9) from a hand slot to pass 24 hours is the maximum of button pushing I'm willing to do :). I sometimes also keep books (first aid, science etc.) for those moments and read them when I have to pass the time (unless I need the points earlier).
Rat Hole is just too early to have books, including “waiting for love”. Then again, it's not a big deal either, there is always the wasteland, it's just a bit of an unnecessary pause.

However, I actually like the feature that resting/healing is "somewhat" disabled. I never liked that option (healing by waiting) in FO. It's just not always optimal in 1.5.
The best thing would be if there would be a waiting option (no heal, like waiting at a train-station, which can be very stressful and exhausting) and a resting option (heal, like at a hotel room (as if it were a doctor)), but I assume that's not easy, or even impossible, to do with FO2.

I think that a character can heal by waiting was never really a good mechanic. Perhaps realistic to some extent (then it becomes unrealistic again). But the option to wait only (to have time related events) may have been better, than combining it with healing.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Thu Jun 28, 2018 10:34 pm

http://www.filedropper.com/slot291errormessage. When using the crowbar to bust open the brahmin pen there is an error message until the pen is opened.
Muttie wrote:http://www.filedropper.com/slot271blocked2. I submitted this before but this time it's during the Crater quest. A bar guest stands in the door and won't let me through (no push option). This happens fairly regularly as a consequence of “reluctant combat”, (i.e. when I try to kill Clark in the distiller room, while trying to avoid to get into a fight with the other people at the bar (to avoid the karma loss). But it is not a big deal. I can restart combat, land one hit, get the guest to run (which opens the exit), and then end combat again (seems to work rather smoothly). I can also walk up to them before ending combat and they continue to run. Both options only have the risk that companions continue the killing of guests. However, trying solve the quest by killing Clark, but without killing guests (and taking the -10 karma from each) is probably a dumb idea anyway. (There is a 1000 caps and a speech option for that).
I said this doesn't matter that much, as avoiding the karma loss in the fight is not that important (or even intended!). However, I recently played through the casino fight in Lost Town. And there the “inhabitants of Sedit” would run away when I talk to them.
And it occurred to me that could be a neat solution for the Crater fight as well.
Some patrons may be set on attack (like the cop in the casino), for example Clark, Loiz and the guy in the green shirt (perhaps?), but the rest (or all) can be set to “run when talked to”, to have a “push option” in case the player manages to get out of combat.
Eventually they all get removed from the map anyway. So I think that could be a way to solve that “blockage of the door” scenario should it occur.
EDIT: Or even use directly the second phase of the Lost Town fight, i.e. when starting a fight with Clark, the patrons will run away when approaching them (could be atmospheric). I think they already do that when in combat. And a few (like Loiz etc.) could attack instead as does the cop at the casino.

Sheriff Carpenter bug
http://www.filedropper.com/carpentersafe. You can see that Carpenter faces towards the safe. This can happen when using the cook to lure him out of the room and then run into him or stand in his path while in his office. This is in so far important, as it seems much more difficult to reach the safe, when he's standing like that (needs about 81% sneak it seems). And as the cook trick can't be repeated, this would be a tough situation.
(When he faces the desk it starts working with 41% sneak, I would say, or even 19% if treading carefully)
However, this is not a big deal as it only happens to players who mess with “Carpenter's walk” (i.e. when the player waits until the last second to run out of the room and collides with Carpenter.) So this bug is easily avoidable. In fact I'm not even sure it's worth mentioning, other than making players aware of it, and not to cause it.

Missing Gabriel trigger?
I went Gecko-Hunting with the tribe, but when the conclusion came I switched sides (the route was: “collect proof” to “Falber” to “Herman” to “Falber” and then “the attack on the tribe”). When I reported back to Falber I got 10.000 (another time 5000) caps. In both cases Gabriel did not ask for his cut. Is that correct? I mean he does ask for 1000 after attacking the hospital with the tribe, and he should probably ask for more when working for Falber. Is this caused by switching sides? Or does he never ask for a cut when working for Falber?
May check from here http://www.filedropper.com/slot290gabrielreward.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Tue Jul 03, 2018 9:55 pm

Muttie wrote:During the Rodriguez quest to face the raiders, I did get 35 points of karma (5 per kill), which put me below -50 and consequently Gabriel left me after that fight. This may need looking into as the Rodriguez quest line working against Gabriel is not optimal. And this is not similar to the first quest were I can solve it peacefully (positive karma) or kill the drunk (negative karma), as in the showdown with the raiders, there is no choice, only combat, (not even staying in the back does work, as it seems I get the points no matter who kills the raiders). I think it may be better if that fight would be karma neutral (i.e. the quest and killing those raiders). Especially as it's not easy to get the karma down to -50, other than skipping New Hope quests. I had to come up with a strategy (graves, ripping up letter etc.) to balance the karma gain from New Hope (I could have gotten more out of the necklace quest perhaps, but, still, it is a bit of a squeeze to pick up Gabriel quickly, and if then going directly in the Rodriguez quest (which can make sense) and running into a chunk of 35 points can be a game stopper. This Karma is also not necessary if accompanied by Lystra (e.g. before that quest one has an option (good/evil) and after it she refuses to help anyway). So I would suggest to consider making these Raiders Karma neutral (i.e. it's dealings among gangsters, and killing gangsters for gangsters, doesn't have to be a good deed). Also if this quest gives +35 Karma, there is basically not much quest line choice in Sedit other than going with Nicol (I think?). Everything else is positive for the most part. EDIT: Well, Lost Town has several negative Options, but still...
I wanted to add that the player also gets +5 karma for every Mexican killed by a Raider, which can make this Rodriguez quest rather Karma intensive.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Mon Jul 16, 2018 9:49 pm

Muttie wrote:Missing Gabriel trigger?I went Gecko-Hunting with the tribe, but when the conclusion came I switched sides (the route was: “collect proof” to “Falber” to “Herman” to “Falber” and then “the attack on the tribe”). When I reported back to Falber I got 10.000 (another time 5000) caps. In both cases Gabriel did not ask for his cut. Is that correct? I mean he does ask for 1000 after attacking the hospital with the tribe, and he should probably ask for more when working for Falber. Is this caused by switching sides? Or does he never ask for a cut when working for Falber? May check from here http://www.filedropper.com/slot290gabrielreward.
Apparently Gabriel does never ask for his cut when attacking the tribe. Is this an oversight? He could at least ask for 2000 caps. Or for 1500 from the 5000. And 3000 from the 10.000?
I kind of suspect this is a bit of a workaround as companions don't work so well in this fights (no Stun Batons, so they kill a lot of people unless someone works around that, either by switching sides (from the tribe to Falber) which has one find 6 Stun Batons or having high Melee and 2 Bonus Move which allows to pick off most enemies the companions shot at). However, most times companions are probably left behind and the player decides to hunt alone, I guess, especially as the fights are not that difficult. The mercenaries can usually handle it alone. And it may feel unfair if a player picks up Gabriel after the final battle and then suddenly has to pay him his share. Although Gabriel is evil, so why wouldn't he ask for his share, even if he did nothing...?
However, what about placing two dead mercenaries on the “Camp of wanderers” map, aka the first donor hunt, which is arguably the toughest (so two dead mercs may underline that) (perhaps they are from a previous attempt to attack?), and each corpse has an “empty” Stun Baton on him? This way a player could equip two companions for the remaining hunts and the final battle, which should not make a big difference difficulty wise (I think) but it would only make the fights faster.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Fri Aug 24, 2018 12:48 am

Doctor Moore
Muttie wrote:When killing doctor Moore, and then leaving before looting his body, and then not helping Alexa with her attack, causes Moore's 13 caps to be covered by the blood stain and they can't be picked up. (...).
Actually it works to use the T hotkey, :roll:, “welcome to 2018” :).
This should also work for Vex's head, actually.
And the odd trick/exploit of getting Lucy's necklace twice should work with this too (i.e. “companion kill” on Lucy in the bar, try to get out of combat, let her body disappear, loot the wall-safe, and then use T key to pick up necklace from under her blood stain).

Avira AntivirPro detects “fores_config.exe” as a suspicious code, it's reference/description of it is HEUR/APC, and wants to delete it. Malwarebytes does not have a problem with it. Nor does Antivir when offline, funny enough (cloud something?). I'm sure it's not malicious, but it may be better to avoid such detections, if possible, as it may encourage people to delete it and/or distrust the mod.

Ben: blinded by pining
Normally attacking the tribe removes Ben (actually it seems to be “killing Aleea”). However, when I work for Falber but don't participate in the attack (say “no” to Falber or ask to get paid first after getting Herman's permission) then Ben is not removed during the attack (i.e. the cutscene that plays when entering the Suburbs doesn't remove him). Instead I can talk to him and get the earring etc., but of course it's impossible to do anything else, as the tribe/Aleea is gone.
http://www.filedropper.com/slot292benremoval. (you can either participate now or say no to Falber. This is also before getting permission from Herman so you can try that too.)
Secondly, and this is probably worse, when I have established a relationship with Ben, then participating in the attack on the tribe (Falber quest), or killing Aleea, removes Ben from his house, and he's not coming back. One could argue he runs away once Aleea is kidnapped/dead (which makes sense normally) but in this case (“relationship”) one could argue that he moved on and should be over it (as he's with the player-character now). The fact that I cannot attack the tribe/kill Aleea without losing Ben, is something I'm not really happy with. It can make sense, of course (Ben feels remorse), but I think there should be an option to “trick Ben” and “betray the tribe”.
http://www.filedropper.com/slot294bengone. (this is before everything, so you need to establish the relationship with Ben, then betray the tribe (i.e. talk to Falber), permission from Herman and then attack (Keri is already equipped with a Stun Baton), Ben will be gone and not return, no matter what).
Isn't it possible that instead “removing Ben” (when Aleea is dead) he is always “moved to his house” instead (as he does when entering the relationship with him or telling him that Aleea has found someone else) and then he either “::sobs::” (floater only) or is open to dialogue (when relationship established) (or perhaps even always open to dialogue when the player is female. It could simply enter the “she was not the only woman in the world” dialogue path and then he either agrees or goes to ::sobs:: depending on CH).

Then there is a minor glitch. When I arrive at AQ with Frederyk's special caravan (Frost is alive) and then travel the wasteland until the next Sedit Caravan is in town then the Sedit caravan leader is at the gate and not at the shelter next to the beam. All other caravan leaders (Crimson & Sedit) are positioned normally, only the Frederyk's Dream one takes the “arrival spot” of Frost (at the gate) and also walks to the shelter after talking to her (you can check that in the Slot292 linked above) or reproduce it from:
http://www.filedropper.com/slot293aqcarleader (this is in front of Frost and you need to travel until the 6/7, then the 21/22 and so on to get the female Caravan leader, and she'll always be at the gate). However, this is just a minor glitch, no need to fix it really.

Then I have an error which is probably not a bug but a corrupted save (bugger). http://www.filedropper.com/slot302aleeagone. In that save I can't get Aleea to spawn at the Wild Paradise. Everything is normal (Madame Chow dialogue option, collecting her earnings) but the room is empty (i.e. it misses out on the last dialogue with Aleea). I tried it with a different character (works fine), then with a previous save of the bugged out character (it is at the start of Corath) (and the same issue: http://www.filedropper.com/noaleeaemptyroom) and then I tried the save above (Slot293AQCarLeader), which is also the same character, but much earlier (and it took a different quest path) and Aleea spawns just fine. So, unless it's a bug caused by (?) my saves probably got corrupted, which is a bummer, really. Anyway, I tried several things (travelling, paying for Gabriel, killing Ben, violence settings, changing orders), but Aleea just won't spawn. However, this is not that problematic, the only thing I'm worried about is, that other elements of the save may be corrupted, too. Is that possible? And is there an option to fix the corrupted save with something from the working saves?

Gabriel at the WP
In the same save (Slot302AleeaGone) there is enough cash to treat Gabriel three times at the Wild Paradise, until he is not allowed any more service. However, after the third time, the option doesn't switch off him. I can pay once more (400 only, leaves a blood stain) and only then it switches to Keri permanently.

Then there are two missing triggers, which are both similar. After defeating the hospital one reports to Gurgan, and if he's dead to Rua. However, Rua is missing some triggers.
First, http://www.filedropper.com/slot295gabrielreward (just talk to Rua and the 1000 caps demand by Gabriel doesn't trigger, as it does when reporting back to Gurgan.)
(Note: When accepting to work for Falber Gabriel makes a comment that those tribals pay poorly. There is also an adjustment in Gabriel's comment when the player has no 1000 caps to pay him (“that's what you get for getting paid in furs”). Perhaps a similar comment could trigger when accepting Gurgan's quest “to find out who is responsible for the attack”, like “What do you think about helping the tribe?” Gabriel:“If you want to play good Samaritan, that's your problem, but I'm not going along with it unless I get fucking paid. And I doubt these butt-naked primitives carry anything of value (on them). (joke, which isn't really funny, and may confuse:) (But who knows, [he looks at you with a grin] there may be more than meets the eye.)“ to have a “can't say he didn't warn the player” comment (i.e. the PC may end up to have to pay Gabriel without having any Money and the quest itself doesn't pay). But, it's optional/just an idea.)
And second, http://www.filedropper.com/slot296ruabug (This save is missing a trigger that occurs when I attack the hospital and then join the Mutant Hunters before reporting back to Gurgan/Rua. If I do that (i.e. the Herman quest) then Gurgan will not reward me but only spawn angry red floaters. However, Rua doesn't react and it allows me to get the reward, become a Tribe friend and join the Mutant Hunters. However, I need to do the Herman quest first as I did in this save, as the Mutant Hunters react to Tribe Friend. Here's a screenshot of me being both: http://www.filedropper.com/huntertribefriend.
Side-note: I'm not sure if Rua should get an angry red floater like “Gurgan and the rest of the tribe” do, or just a single dialogue exchange (“you helped us but you're not our friend”) but then keep the dialogue with Rua open for the “soul searching” option. As that's what Rua does at the moment (i.e. no matter what I do, I can always talk to Rua, even if the rest of the tribe doesn't like me anymore). The only exception is failing the “blood reading” and getting -1 LK, after that Rua will never talk to me again (which, btw, also cancels reporting to Rua in case Gurgan died during the attack.)
Anyway those two Gurgan triggers (Gabriel reward and angry floater) are missing for Rua it seems.

Lystra and the Law of the Ring.
I think Lystra loops in the ring fights. She looses to Cedrick & Blaster (both is fine) but against Chadwick and Bill she gets stuck in a loop (tested with Robes, Kevlar and Combat Armour). Bill/Chadwick always miss, while she always hits. And it goes on for minutes (had to use the windows key to get out.)
http://www.filedropper.com/slot297lystraloop. (You can do both fights from this save).
Not sure if Lystra should beat Bill or Chadwick, probably not, however, I'm not sure if it's the missing dialogue after she won (Keri and Gabriel both trigger a comment) or the exile cutscene that fails to play. Or if it's the fight, that gets stuck in animation. Perhaps it's a problem of the censored version?

Lystra and the injured miner.
When I talk to doctor Linsday and the miner is hurt, I get the chance to offer my expertise (with the option to back out again) or say “I won't interrupt”. When I say “won't interrupt” the option to heal the miner is gone. Which is fine, except when Lystra is in the party. As ending the dialogue with Linsday (in any way) triggers a comment by Lystra regarding her doing the operation, but when I did chose “I won't interrupt” it leads to nothing, as I can't make the offer to Linsday any more.
You can test that in the same save as above (Slot297).
Perhaps Lystra's comment shouldn't trigger by “talking to Linsday” but only by using the “I can help” option. Although I don't think Lystra should just stand by and do nothing, but always comment, and operate, as long as she is in the party. (I think the comment fits both occasions. Asking her “if she would do it” and asking her “if she feels up to it”.)
Or, alternatively, saying “won't interrupt” cancels the option as usual (which is fine), but it triggers Lystra's comment (as it does currently) which then reopens the option with Linsday (i.e. her comment triggers the “Could Lystra perform the operation” option in the Linsday dialogue.)
Lastly, Lystra being in the party (even without comment) could be enough to open the “Could Lystra perform the operation” option. At the moment the option already changes based on Lystra being in the party or not. For example, I can toggle the option on & off by adding/removing her from the party, and then there is the peculiar case of her learning that her brother is dead (removes her from the party), then I do the first Chadwick quest, wait 24 hours, talk to Linsday (offer help) and then get Lystra back in the party: and the option is there (it just skips her comment).
So the option (“Can Lystra do the operation”) could actually trigger when Lystra is in the party, and not only when Lystra is in the party and after offering help.

Gurgan and hunters' death
This is a minor issue, but when I kill all hunters during a gecko-hunt, then Gurgan will not send me on another gecko-hunt. Which is fine, however, during the last hunt (the ambush) all hunters can die. (Either by my own hand or by Keri with her “friendly fire” SMG). When I return I get the quest (find out who is responsible...) as usual. The odd (bug?) is that the next time I talk to Gurgan I get the “all hunters died” & “you can't go on another hunt” message which ends dialogue. This may confuse, as it suggests that Gurgan is angry, but it really has no consequence, just talk to Gurgan again and report who is responsible for the attack etc. (I tried this “before and after” collecting the proof, and the message always triggers, i.e. it is always Gurgan's second comment when talking to him).
http://www.filedropper.com/slot298gurganresponse (this is on the “ambush-map” and all hunters are dead, killed this time by “friendly fire” aka Keri and her SMG. You can return to Gurgan, report and the second time you talk to him it should be the “no hunter returned” comment).
This is not a big deal, and the fact that the quest is given no matter what (e.g. all hunters died or by fleeing off the map) is good (especially the option to flee). The only difference, as far as I can tell, is that when all hunters died I don't get the +10 karma from Gurgan, which is fair.
However, the message that “all hunters died” shouldn't trigger, but skipped in that case. Or it needs to adjust the quest dialogue to something like “all hunters died, we need to find out who did this, before it kills the entire tribe, no hunters means no skins, no skins means no tribe etc.”.
Side note: the “you run away/coward” comment by Gurgan does not trigger (when running away from the ambush) only the “no hunter returned one” does.

Here is a minor error. The cell-door keeping David is only closed but not locked when loading the Suburbs for the first time, only entering the map a second time also locks the cell.
http://www.filedropper.com/slot301opencelldoor. (This save is shortly before AQ, the note (that spawns David, is in the inventory and not read yet). So read note, enter AQ, get the William's quest and use Sex Appeal to get in the basement (quickest way) and the cell-door is not locked. If you enter the basement by fighting it's the same. However, if you do the same as above but leave and enter the Suburbs once (in any way, including entering AQ without reading the note, then enter Dead Quarter, read the note there, and then return to the Suburbs), then the cell-door is locked. So it's the “first loading” of the Suburbs map that closes the door (if David has been spawned), but doesn't lock it.
Side-note: the cell-door key (on the ganger) spawns immediately (i.e. when reading the note). Only the cell-door needs to load the Suburbs a second time to get locked. However, it's not a big deal as opening the cell-door should never be an issue, it's just cosmetic/role-play.

Additions to the AQ crash (not again...)
Testing the cell-door, required me to enter “AQ for the first time” repeatedly and it worked (to my surprise), but once I had massive stuttering again (which is very rare, only had that happen once before), and eventually a few crashes (nothing new): “Instruction 0048b439 at referenced memory 00000001" when entering AQ. “Instruction 0048b1f2 at referenced memory 00000000" when trying to save in the basement. “Instruction 00489467 at referenced memory 00000004" when trying to leave AQ to the world map or Dead Quarter. I tried to fix it with my usual method: loading http://www.filedropper.com/slot04aqfixfemale (entering Downtown, save, load, enter AQ) but it didn't work this time. However it did with this one http://www.filedropper.com/slot43aqfixmale (same method: entering Downtown, save, load, enter AQ). And another save (also male), that didn't work previously, worked this time too (different sex or character?).
My version is censored, does that matter? Is there anything on the Suburbs a censored version struggles with? I don't think there is, and if it should crash all the time. However, I did stumble over an issue (dead quarter operations, see below) were the censored version causes only occasionally a crash, which had me wondering again.
The cell-door error also had me wondering if this “first Suburb map” is sort of unique and special, and if this could be a part of the “first AQ visit” crash? I also had a few old screenshots in connection to crashes on AQ (http://www.filedropper.com/aqhighlight). On each of those screenshots were elements on the map highlighted, and those games did crash when I tried to enter Hunter's Territory. Perhaps it's a map error.
These highlighted walls also play into an old suspicion of mine (or should that be superstition :) ) that part of the problem could be that I'm using shift to run (highlights items). As I had odd behaviour when I hit caps lock by accident (the shift key stopped working once, and capslock couldn't be turned off anymore without leaving the mod). And once I got kicked out of the mod as Windows wanted to know if tapping shift five times should lock in caps lock. I then selected “No”, reopened Resurrection (via task manager) and found that caps lock was still on (tested by naming a save game, which was all in caps) but it was not according to my keyboard (no light indicator), and neither in open office. In fact I had to close the mod completely to turn off caps lock. Anyway, this had me wondering if the mod may get messed up by excessive “shift” use. However, I had this happen again (caps-lock can't be deselected) but I couldn't reproduce it. Not sure what causes it. It's probably nothing.
I also had odd skips, as happens in Corath. I loaded a game in AQ/Suburbs and instead I ended up on AQ/Hunter's Territory. Another time I ended up on the world map. As this never caused any problems, and is not reproducible, I didn't pay it much attention. However, considering the AQ issue, the first map etc., perhaps there is something wrong? Actually, this also happened in Sedit once, but I can't remember exactly how and where. It's actually very rare.
(Anyway, these were a few snippets I had still lying around and I won't mention the AQ crash again, swear, probably...).

Note on AQ kidnapper
It seems there is no reason to talk to the “contact man” in AQ, other than learning that Vex did it. But a player who knows that Vex is behind it, can get David the moment the note has been read. The only thing this might miss out on are the 500 XP from Kevin/Sedit Caravan. (Although they can be collected as long as David hasn't been returned home yet, aka entered Downtown).
As the contact man has an unique set of requirements and triggers comments by Gabriel (will go to Vex) and Lystra (about Vex) perhaps add a 250 or 500 XP reward for getting the information (by intimidating him or paying caps, but not (!) by fighting/killing him, as the red floater, aka failure to get the “detailed info”, doesn't trigger the Gabriel or Lystra comment). This could help to make this conversation, and solving it, a more regular stepping stone in the quest line. Otherwise I can just skip it, and never bother to get the “detailed info”.
Also the contact man reacts to Vex death (dialogue adjusts) but not to David being freed. I can kill the entire gang and have David with me, he doesn't react (normal dialogue). However, Vex does react when I have David with me (angry/red floater and attacks), and the contact man may get the same trigger. Some floater when approaching with David in the party, like “Oh, shit they found the boy.” and runs away (or attacks), although I like running better (however, that may need a screen-fade/cutscene, which may not be optimal). Although he may also keep his cool, and act dumb (which may make more sense), and having freed David only ends the dialogue options (he could say instead “No idea, what you are talking about [glimpses nervously at David]”) and then it could basically end like the normal dialogue (fights or runs away). At the moment he only seems to despawn when David has been returned (i.e. entering Downtown).

Fight on the Suburbs & Alvarez
When fighting Vex it happens that they hit immigrants who then join the fight. This is fine, however, it becomes annoying when Alvarez joins in as he moves out of position and never goes back to his shop (as it was in FO1 during the LA Boneyard fight for Adytum, which sucked). Having shop owners displaced isn't optimal and, consequently, is it at all possible to reset Alvarez when combat ends (walks back or cut-scene reset)? I know that Rua walks back to his tent when ending combat with the tribe. And Vex is always teleported back to his standard position. For example when I start combat and pull him out of position, and then leave and re-enter the Suburbs, he's back at his normal place, while the rest of the gang isn't (explanation: I tried to get in the basement). Which may be another option. Or, another idea, you could break both his legs so that he can't move? … What?! ...It's a reasonable request… (EDIT: don't know what I was thinking, but both legs being crippled shouldn't immobilize.)
Anyway, it is also possible for the player to contain the fight and not let it spill to the south part, which pulls in Alvarez, but if there's an easy way to stop his displacement, it would be nice.

ST Operation possibly collides with censored version
I think there is a bug regarding the Strength operation in Dead Quarter/AQ. However, it is oddly irregular.
http://www.filedropper.com/slot299stoperation. This save has Gabriel and Keri in the party. I can now sell Gabriel, then swap Keri plus 10.000 caps for +1 PE. This has Keri's corpse glitch out (minor bug) (screenshot: KeriCorpse & KeriCorspeOutside). And so far I always got this “standing/falling body” glitch when selling Keri.
The more problematic bug is when swapping Gabriel and 5.000 for +1 ST. I tried (dialogue with Falber:) 3/3/1/1/1 and 3/2/3/1/1/1 and selling him for only 5.000. Sometimes it worked, sometimes it crashed: “Instruction 00471b99 at referenced memory 00000000". However, it's like 3 out of 10 crash (and 3/3/1/1/1 seems to crash more regularly). Another time it spawned the wrong corpse (a civilian corpse with Gabriel's description: screenshot: FalseCorpse), and when I removed all items (but armour) from Gabriel, I had repeatedly no body spawned (screenshot: GabrielNoCorpse). So it may have something to do with the corpse that causes the crash, either in regard to items, spawning it or perhaps in relation to the violence settings (I do have the censored version). The last may explain the Keri glitch (should be cut up it seems: screenshot: KeriCorspe2), however, it does not really explain why selling Gabriel crashes sometimes, but not all the time (as issues with censored content used to crash consistently (so far)).
I also tried Lystra: http://www.filedropper.com/slot300inoperation. And it's similar to Gabriel, sometimes I get the standard body (screenshot LystraCorpse & LystraCorpse2), once a false body (screenshot LystraFalseCorpse) and sometimes no body (screenshot NoLystraCorpse).
The last (NoBody) triggered when I changed the violence settings. I first had a standard body spawn (settings on maximum) (dialogue: 2/3/5/1/1), reloaded and changed the settings to minimum (and got no body), reloaded (which had the settings back to maximum again) and it crashed: “Instruction 0042de05 at referenced memory 00000184" etc..
I then tried to reproduce it but instead the crash I got repeatedly “no body” outcomes (about 4 times in a row). I then reloaded Gabriel and tried 3/3/1/1/1 and it crashed as described in the Gabriel section above.
I also had a crash with Lystra when selecting 2/2/4/1/1/1: “Instruction 004af4b0 at referenced memory 000000b4". Another time is was (2/3/5/1/1, I think?): and “Instruction 1000e732 at referenced memory 00000154". So, Lystra seems a lot more inconsistent. Gabriel has always the same crash (so far) while Lystra's save crashed less often and less consistently (three different errors). Perhaps because the save's violence settings are on maximum and not on minimal (?) or her model is different to Gabriel's? But it's most likely the different settings). Anyway this does seem to be a problem with censored content.
This folder has all the screenshots referenced above: http://www.filedropper.com/stoperationscreenshots
Side-note: It should be noted that stats like (total HP, AC and carry weight) don't adjust after the operation until opening the character sheet (you can check that by opening the Inventory screen first, where carry weight doesn't adjust). That had me confused for a while until I discovered it. So it's not a problematic bug, but one that people should be aware of.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Tue Sep 11, 2018 7:07 pm

Here are a few minor points and observations, I came across while strolling the wastes.
But first I feel it's time to point out again how well made the mod is. Even after 9 months of playing it, I'm still loving it. The detail is just amazing, and although this list keeps growing, mostly with oddities and small-time events, it is really impressive how often the mod actually “DID” get it right. That list would be even longer! The stability of the mod (quest design, triggers etc.) is really outstanding, and it shouldn't be forgotten when looking at bug reports for too long. This really is just a small portion of the mod. And I'm still very impressed by it!

Kidnap switch from Vex to small-time gang
During the kidnap quest, a small-time gang will replace Vex's gang. I think there is a problem regarding the trigger. I believe the trigger is entering the suburbs when 1.) 8 gang members have been killed (not counting Vex). And, 2.) the note has been read (which spawns David and locks the cell door). When both is true the game adds 3 gang members to the basement when loading the Suburbs.
The problem is that when I attack Vex, do the above ground fight (which kills 8 gang members) and then leave to the DQ hospital for healing, which makes sense, I'll trigger the switch and have 11 (8+3) gang members in the basement (and two keys).
It took me some time to figure this out (originally I thought this is correct), but all considered it probably isn't. (Especially as it looks odd as they spawn on top of each other). I also believe the “removed 10mm SMG ganger” when using the Black Widow option on Vex, is actively avoiding this issue (i.e. it reduces the gang above ground from 8 to 7 (aka one below the threshold) once the gang turns hostile.) However, the “healing in DQ” scenario isn't covered, and may trigger rather regularly. After all, it only takes to leave the Suburbs once after wiping Vex and the 8 members with him. And that is not unlikely, as a character may, for example, heal at the hospital or clear inventory space by selling items to Chuck, before going down the basement.
I think the most optimal solution would be, if the “substitutes” would only spawn when Vex's gang is gone. One way to do this could be that once Vex is dead, his entire gang (all 16) are removed when accepting the kidnapping quest from Bruce Carpenter. And the moment David spawns back into the game (aka reading the note) it spawns a “substitute gang” into the basement should Vex be dead. Which could also be a bit stronger than just a gang of three (perhaps 5 to 6?). And if Vex is alive, reading the note only spawns the key, as it does right now. Wouldn't this cause the least complications? At least I don't think that “Vex: alive/dead” could fail as a trigger to replace his gang in case of the kidnapping? Besides, Kevin's contact man in AQ already adjusts to Vex being dead or not (?).
Another problem is that the 3 new gang members spawn at any point after the trigger (aka 8 dead and note read). For example, when I clear the basement, take David, but then return to it, as I might have forgotten to pick up an item or did not had enough inventory space at the time, then there will be suddenly 3 new gang members in the basement, which isn't optimal either. So perhaps the end of the trigger may need adjusting, too. (Currently it's “returning David home (aka entering Downtown)”, I think (?), and perhaps it needs to be “opening the cell door” and/or “recruiting David (aka having him in the party)” that ends the spawn, if that is possible?
Just in case: http://www.filedropper.com/slot303kidnappbug (In this save I have the note (not read yet) and I killed all of Vex's gang above ground, but one, who ran away (long hair dude). You can now test all scenarios: leave the map, read the note and enter the basement (result: David and 8 gangers). Or you can enter the basement (take Psycho) then kill them all (or only one), leave the map, read note and enter the basement again (result: David and +3 gangers in addition to the remaining ones). Or kill the long hair dude above ground, leave the map, read note and then enter the basement (result: David and 11 gangers (8+3) spawned on top of each other). Last, you can also leave the map, read note, wipe the basement (8 ganger), pick up David, leave map, return to basement and the 3 substitute gang members should have spawned in it.
Simpler solutions could be to set the threshold to 9 gang members, i.e. 8 + “One more” (who, by default, has to be from the basement). This way triggering the “small-time gang” would have to be very deliberate (i.e. into the basement, kill one, leave basement, leave map, return to basement). Or, similar to the Black Widow option, you could instead remove one of the gang members above ground permanently (like the one with the Knife). But I think the suggested trigger (Vex dead: gang removed when accepting the quest) & (Vex dead: substitutes spawn when reading note) should be cleaner, as it would be always only one of the two gangs present, and never a mix up.

Minor oversight at the sheriff's villa
When I got access to the villa (after accepting the quest to find David) I can use the standard “What is this place” dialogue option with Jeffrey, and get access anyway. However, when I choose that option with John, I don't, it plays the standard path of “This is the sheriff's villa. I won't let you in”. This is a rare occurrence as those options are usually used up at this point, but when the mod adjusts for Jeffery you can probably copy that over to John easily. http://www.filedropper.com/slot304johnenter (for convenience).

Gabriel & Lystra comment
When learning from Kevin's contact man at AQ that Vex is behind the kidnapping, the comments by Gabriel (wants pay) & Lystra (about Vex) are not reacting to Vex's death. This is a detail really but for the most part the mod pays attention to such changes (for example the contact man himself adjusts), and their comments (Gabriel & Lystra) are one of the few exceptions to the rule, and could be adjusted based on the same trigger.

David Carpenter
Once he becomes a companion he is apparently not set as a “child” anymore, as killing him doesn't trigger childkiller. It does when I kill him before “recruiting” aka “rescuing” him. I'm not sure if it is worth bothering with this, but Childkiller may trigger the moment a “recruited” David dies, no matter who killed him (i.e. the -15 karma that trigger when he dies, may also trigger “childkiller” as one is to blame for his death, perhaps?). This is a rather minor point, but killing David accidentally in a burst, or losing him to an encounter, marking one as a Childkiller, in addition to failing the quest, could be funny.

Suggestion on Carpenter reward
Gabriel could ask for a reward after returning David. This is not as big a deal as the Dead Quarter hospital where Gabriel makes a comment how well the doctors pay but then never asks for his cut in the end. But, besides that, I feel Gabriel should get in on any major reward. And the 10.000 by Carpenter is such a reward. He does ask for 2500 when learning that Vex is behind it, but I think he could ask for another 2000, 2500 or 3000 when collecting the final pay. Perhaps with a dialogue like: “Fuck me, that's a nice sum for saving a worthless, little (maggot/shit). I still think we could have made a better profit with Vex, but don't mind me. [He holds out a hand]. Although (2500/3000) barely pays for the pains of travelling (the wastes) with a (crying) child (with that useless, little snot-nose/shit).” Reply “Here you go [throw him (a purse of) # caps].” or “You bastard, I'm fed up with your attitude and demands, I'll pay you nothing!” Second warning: “So this is how it ends then, is it? With you dead and me taking the whole purse from your (mutilated/broken) body. That's going to be fun. [He grins wolfishly.] ” Reply: “Relax, take your 3000 caps and shut up.” or “Come and get it, motherfucker!”. Or something like it. (You never have to use anything I suggest. It's not what I think “must be done”, nor will I be disappointed if it has been ignored. I just don't want to be that guy who just points and says “fix it”. So, at the very least, I want to put in a little effort. And I always sit down and put at least a few lines, ideas and solutions together (as hopeless and ignorant they may be at times). Well, and it's also a bit of fun, really. Work, but fun.

Karma is weird
I recently changed the ddraw.ini to display karma changes (a small step for mankind but a big leap for me), and it plays normal for the most part, except for an oddity during the rescuing of David Carpenter. When I spare the Nanny I get +10 karma, but when I blame her I get -10 (blame her?), another -10 (she gets killed?) and then when I click the next reply option I get +10 (go look for David at Little Hub). Aren't the last two karma changes superfluous? I don't think there is any alternative option (i.e. the dialogue with Carpenter is very straight forward, other than the blaming decision. Unless I'm missing something). I think I even got -20 karma once (before the ddraw.ini change), which puzzled me, I then repeated it and got only -10. So I thought I made an error, but in hindsight it actually may have bugged out on me once and gave me falsely -20 karma for blaming the Nanny (?).

Keri karma exploit
The karma option with Keri are great (+2 for preaching to her) and (-1 for insulting her father), however, there is another one which gives +1 for telling her “I'm sorry”. That one is exploitable as I can repeat that dialogue part endlessly for endless +1 karma. Personally, I would remove the +1, just have a plain option to say sorry, as I think two karma options are enough. Or you need to cancel the dialogue at one point (as it does when going the preaching/insult routes) or just leave it in, as it's just a minor exploit. (The sequence I used with Keri for 67 points of karma was 1/1/1/1/2/1/2).

Missing wall piece
Here is another minor map error on the Suburbs map of AQ. (http://www.filedropper.com/missingwall). The wall next to the door of Catherine's house is missing. This save did not crash when entering AQ etc., the wall just continued not to be there. However, I've never seen this before (maybe once, though?) and I have no idea how to trigger it. And I lost the save as I was playing casually (aka not bothering to make a proper report, and I snapped out of my laziness too late).

Staircase at Uncle's place (Corath)
I noticed that the PC is always walking around the stairs when trying to descend to the ground floor. Which is not a big deal, but slightly annoying over time, especially as this does not seem to be the case with other stairs (like at the Wild Paradise, or at William's house).http://www.filedropper.com/slot305unclestairs
At the WP I can stand on the top of the stairs (walk onto them), but at Uncle's house the move cursor features a X. And in William's house the stairs are close to the wall, and always used “normally” from the right. (nagging wife voice): “Why can't we have nice stairs like the people in AQ? My mother warned me against moving to Corath but... etc. etc.”

When doing Lystra's quest to find her brother, one has to talk to Falcon first. Doing this does not put Corath on the map, which is an oversight, as Falcon says “go to Corath”, but not “where Corath is”. This is an oddity but a character “may” end up in AQ before visiting Sedit (i.e. talking to Gregory and/or taking a caravan to Corath). So Falcon should put it on the map. http://www.filedropper.com/slot306falconcorath (if you need a shortcut).

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Sun Nov 11, 2018 12:30 am

A few more collected points. Some are bugs, some are observations, some are suggestions. As usual you have to decide what is important and what isn't. I tried to be as brief and thorough as possible, and as that's a contradiction I probably didn't achieve either, lol.

Minor design issue: In the character screen the headline of the Melee Weapon and Outdoorsman skill descriptions reach beyond the window. Which in both cases leaves black spots when selecting another skill until refreshing the screen. And in the case of Melee Weapon it also makes the last part unreadable (the “+ ST” part is outside the window). FO2 RP Mod has a similar issue, except that it uses a smaller font (I think) and only Melee Weapon touches the border (leaving the black spots) but that's a minor thing really. Anyway, you may check FO2 RP Mod and consider using that font size and/or phrasing for the skill headlines, especially for Melee Weapon.

Sabrina Hostility trigger: Another minor one
As mentioned before there is this mechanic that hostility needs Line of Sight (or something like “detection range”) to trigger. And some characters that should attack after being offended don't or only attack with delay (like when walking closer to them or behind the LoS blocking object like a desk or counter). Normally, this is not an issue, as that scenario usually occurs naturally. However, I found another one which is not problematic as such but a bit odd: when flirting with Sabrina in Sedit, she rejects and if then offending her, it probably should cause hostility but because of the locked door it doesn't trigger. And the player can continue to talk to her as if nothing happened. This is not a big deal, but perhaps the “offending line” could cancel dialogue with Sabrina, rather than triggering hostility? Especially as the only option to trigger that hostility is to lockpick the door next to her and that seems to trigger hostility anyway. No matter if I talked to her first or not. So the option to offend her as a male appears to have no actual consequence.

Companions leaving party: thoughts and suggestions
When I played around with Drools I played around with other companions as well.
During that I found that:
Gabriel does leave me (unless I pay) when: accepting to kill Rodriguez. And when learning that Vex is behind the kidnapping. In both cases Gabriel seems to disappear from the game (?). I thought about this for a while, until I realized that Gabriel going to Vex probably kills him (Vex hates Gabriel). And wouldn't it be funny, if Gabriel betraying the player by selling info to Vex would put his corpse at Vex's place. Perhaps with a comment when looking at his corpse like: “Seems Gabriel lost his last gamble. See you in hell, bastard.”
In the other scenario, Gabriel could return to his spot at the casino, and turn hostile with Rodriguez's gang, as he does when the player attacks the mafia without having Gabriel recruited yet. Why does he just disappear instead? (Note: It seems that recruiting him seems to remove him from the gang of Mexicans, i.e. when asking him to wait, and he returns home after a week, he does not react when attacking the Mexicans.)
In addition what if the disappearing Gabriel has quest items in his inventory, wouldn't they be gone, too? And wouldn't it be better if Gabriel returns into the game in both scenarios (once alive and hostile and the other time dead)?
The same goes for Lystra when she searches for her brother alone, or leaves after the Aran thing went down. In both cases her inventory disappears with her. Perhaps her corpse may appear somewhere, too, when she decides to travel alone. That could be rather cool actually (like finding her dead in Corath or, even better, in a special encounter that could trigger a week after she left: “The search for her brother has come to a tragic end. Poor, Lystra.”, perhaps with some hint at what killed her, like corpses of ghouls, raiders or deathclaws around her). In the other case when she ran off to save her home (which always triggers on DQ) her stuff may appear in her room (i.e. when Elisa informs the player that Lystra's body has been found outside the wall), or her corpse could actually appear “outside the walls” like among the spikes of the Suburbs map or at the east gate of Imperial City. Although I don't like that one. Perhaps she could just give the items back to the player when she leaves after the Aran thing (similar to what happens when selling a companion to Falber).
Anyway, not sure if this is worth messing with, as losing quest items should be rare. Besides, most quest items are used immediately except a few like electronic parts. Plus the scenario can probably never be fully avoided. For example, a companion may die in an encounter the player has to run away from (all items lost). Or the closing of IC (as may happen when apprehending Anonym) may cancel access to a “waiting” Lystra etc.. However, the real interesting aspect is probably the story development, either by finding Gabriel's corpse at Vex's feet or in Vex's basement or by finding a dead Lystra out in the desert after she left to search for her brother on her own. Both would be very cool additions.

Silly steal/plant XP exploit with companions
Slot310DeadEnd2 (see next point): In this one it can be tested to steal inventory from Keri & Gabriel back. Both are back home (aka CC and Casino). I think they never react to that (steal/plant can fail, but no consequence) and each steal/plant is +10 XP. Which is a dumb exploit, (dumb, as it's a lot of time spend for a few XP), but still an exploit that can be set up (ask a companion to wait, spend a week until they go home, then steal/plant for unlimited XP). Although, if needing XP it's much more fun to just wander around the desert and kill stuff for XP, than spending an hour going through their pockets, so...ignore?
Note: Especially as this exploit helps when losing a companion due to karma or quests, see the previous point (i.e. it allows to get the items back without repeatedly reloading).

Kidnapping of David (minor trigger issue)
I found a slightly unfortunate trigger. I've tested it and apparently Vex will turn hostile when I hit a Sedit kidnapper before doing the final report to the leather guy (i.e the report after the “Nanny is dead” or “the cops followed me”). That report tells me to see Vex (which also appears to spawn David back into the game, i.e. into Vex's basement, and removes the Sedit kidnappers from Vex's gang, so I'm free to kill them :wink:).
The problem is, it may happen that I can't or won't hit a kidnapper. In which case Vex tells me “you got a job to do”, but there is nothing left to do. (The Nanny is gone, killed either by me or Carpenter (I assume), David is removed from the game and the kidnapper is dead).
Here is one example: http://www.filedropper.com/slot308deadend3 (in this one, I did not kill the Nanny but got followed. The cops then killed two kidnappers (leather guy (so I can't report back) and a standard thug). This had no consequence at the time. The remaining kidnappers would neither talk or attack me, so I travelled to AQ (that's where the save is). However, Vex only tells me to go back and do the job. If I do, the remaining two kidnappers are suddenly hostile, and when I kill them, then Vex will trigger the “You messed it up” comment and attack when I get close to him.) This is basically how the quest is supposed to end when I mess up (kidnappers and Vex attack me). It just triggers awkwardly, as it's not “failing” (leather guy died and David won't be delivered) that triggers Vex's hostility but “hitting a kidnapper” (i.e. they eventually turn hostile because leather guy died, and after I hit one of them, Vex will turn hostile, too). I recreated this save (http://www.filedropper.com/slot320noreaction) to show that once leather guy has been killed the remaining kidnappers won't attack me immediately, which leaves me at this odd dead end without directions. This situation only clears up (i.e. into hostility) when I talk to either of them first (red floater) and then leave and re-enter the map. Which is not optimal. I assume the red floater and hostility should trigger the moment combat ends, but it doesn't for me. (Note: Getting leather guy killed is fairly simple, just stand behind him, and press space. The cops usually burst him down.)
In these saves: http://www.filedropper.com/slot309deadend (in AQ) and http://www.filedropper.com/slot310deadend2 (in Sedit), I also got followed by the cops but during the fight it happened that a kidnapper hit a Little Hub inhabitant by accident, pulled the whole map and the whole gang got wrecked. This means I can't report to leather guy, nor can I hit a kidnapper, and Vex never changes his “You got a job to do.” The same thing should happen (I assume) when the whole gang got wrecked by the cops, which isn't likely, but may happen with a few lucky bursts, especially when the player doesn't contribute to the fight (pacifist run).
Isn't is possible (assuming I understand the trigger correctly) to adjust Vex's hostility trigger from “you hit a kidnapper” to “you hit a kidnapper and/or leather guy is dead” i.e. the quest is failed the moment I can't spawn David back into the game (aka into Vex's basement)? This way I have hostility with Vex the moment the quest is “failed”.
Please, remember that the final report to leather guy (which puts David back into the game) should cancel this trigger, so that it's still possible to double-cross the Sedit kidnappers, once they have no use anymore (i.e. as it is at the moment), as that is a rather cool option.
Anyway, the point of all this is that it may be better if the death of leather guy (for any reason) sets Vex and the remaining kidnappers immediately hostile, rather than having to travel (leave & re-enter the map) before hostility triggers, or ending up in a scenario where causing hostility has become impossible (as all kidnappers are dead).

Minor Nanny issue thing
When I'm told to meet the Nanny during the kidnapping quest, and I don't talk to her but just kill her, the quest enters a state of limbo. The kidnappers keep telling me to meet the Nanny, and the Nanny won't return from the dead.
This is really a minor thing (if someone tries to break the game, it's their fault), but is it possible to have the Nanny be a “citizen of Sedit” until initiating dialogue with her?
This would be a slightly cheesy fix, but could avoid the limbo. However, if a player won't reload (after causing town hostility), but flee Sedit and report to Vex it would still be: “You got a job to do” although the player can't go back to Sedit because of the hostility. Still, this may be a bit more satisfying until the player tries to fight his way through Sedit, and then be told by the kidnappers to meet the Nanny (…) (“Back through the whole town?! But I'm out of ammo!”). Not optimal. Unless “town hostility” in Sedit makes Vex (& the kidnappers?) hostile, too, (i.e. the moment Sedit is in uproar it should mean that the player messed up the kidnapping and Vex should attack?). This (town hostility cancelling the quest) could be an option. However I'm not sure how that would interact with other scenarios, like killing the ghouls? Or when causing Sedit hostility outside this quest? I think in the first case, hostility would only trigger if returning to Sedit before the time-period is over. So that should be OK, and in the second case it would need to be connected to the kidnapping quest (i.e. Sedit hostility cancels the quest (i.e. Vex won't give it) and when the quest is already active it turns Vex hostile, and once the quest is over, Vex is disconnected from Sedit again)? Not sure if that makes sense, but “town hostility in Sedit” being a fail-state that triggers Vex to attack during the kidnapping may be an interesting option (see also the next point).
Anyway perhaps this point is not worth bothering with, as the player isn't supposed to skip dialogue with the Nanny. Plus it may cause new bugs and problems etc. But I thought I mention it.

Fighting the Nanny at the CC pen
During the kidnapping I have to meet the Nanny which results in a fight. This scenario is very cool, but it can behave oddly or turn out underwhelming. For example, it is rather easy to stand and fight, as no one reacts to it. Once that has been figured out this scenario always results in all three cops and the Nanny dead (there is not even any need to “run into the desert”, just kill them all and report to leather guy).
Second, it takes very little (like hitting a brahmin by accident) and Little Hub will turn on the cops and wreck them. I also saw the Falcon Flight ghouls and their bodyguards attack the cops as they hit one of the combat armour cops by accident, who then also proceeded to hunt down and kill the Nanny for me (…).
I think this scenario is frightening when played for the first time. And I think a beginner would not dare to attack the cops because of town hostility, and then may find it difficult to take out the Nanny in time. However, that novelty runs out quickly. Especially when companions just stand in the street and kill the cops. Another point is that the nanny is rather aggressive. She very often is actively following me (charging), until I hit her once, after that she usually turns and runs. Knowing this, one can actually run away, and have the nanny following one to the edge of the map, before disposing of her, which feels a bit wrong.
Here are a few thoughts: 1. Can the Nanny be set to “run immediately” (abject coward) making it a nasty: you have only one or two shots at the fleeing Nanny, before the player has to “run into the desert”. And failing to kill the Nanny, would mean the “being followed scenario” would happen more often (which is cool). However, I'm not sure how annoying this would be for players (hunting fleeing NPC's is normally a nuisance), and how intuitive it is for a player to give up the chase and run away. Alternative you could at least disable her charge, and let her just stand in place until she flees. I'm not sure how much is possible but I remember that David Carpenter is very passive as a companion. 2. Make the three cops citizens of Little Hub, so that they a) don't get attacked by everyone the moment they hit a brahmin, and b) force the player to “kill the Nanny quick” or “run” as fighting and killing the cops on the public street won't be an option anymore (causes town hostility). The second group that follows and attacks at the hideout may be explained as “happened in a back alley” so no one noticed it. (It may also be worth it to consider upgrading the 3 cops to Sniper Rifles and/or Scoped Hunting Rifles, so they scare the player off and are more accurate (Long Range and Scope), which may also help with them not hitting the brahmin etc. when using burst).
However, these are just ideas, and probably not good ones (not sure if town hostility can be made to work that way). In fact, this encounter may become very messy if attacking the 3 cops causes town hostility, especially with all the many different factions in Little Hub (ghouls and combat armour cops, normal cops and citizen/caravan guards, the nanny and her 3 cops and last the kidnappers). Although town hostility is currently the major risk of that fight, but not because of hitting the cops, but for the risk of hitting a bystander or brahmin by accident. So the discouragement to fight the cops on the street where a brahmin may get hit is already in the game, just that it's avoidable by being careful (lure the cops around a corner). Perhaps it would need a stronger indicator like Leather Guy says: “If you meet the Nanny and she gives any trouble kill her for all I care, but if you see cops “RUN!” into the desert. Don't start a fight on the street. Having the entire city coming down on us is the last thing we need.” etc. And this way the scenario may play out more often that they either kill the Nanny (not followed) or fail to do so in time and must run from the cops (and will be followed), resulting in a second, tougher fight.
Does that make sense?

Door Block
I had an unfortunate door block. I led the cops to the hideout, fought, took a lot of damage and stepped away from the door to heal. The kidnappers then attacked the last remaining cop (who remained outside) and killed him. Now, they are all standing in the door frame and I can't push them (http://www.filedropper.com/slot311doorblock). I don't think I can get out of this.
I think this is a very rare scenario. But perhaps, all cops need to storm the building (which they sometimes do, but sometimes one remains outside and shots at the leather guy) or the kidnappers need to “walk back into their positions” after they moved off their spots (as Rua does when the fighting ends, for example).

Reporting to Vex
When ending the kidnapping, Vex sends one away. The reply options are a bit unclear (http://www.filedropper.com/vexdialogue), as it's not obvious which is the aggressive one and which is not. Perhaps change the first option to “Screw (you/this), I'm out of here.”

When handing him all weapons you could consider to move the weapons into MacGyver's inventory. There is no important reason to do this except for the Gold Nuggets, which are classified as weapons, and needed for the Ghoul quest. Losing the gold nuggets this way should be ultra rare, but if it's not a big deal (?). Besides it may be nice if the player can steal the weapons back (may be an option to reloading). Or remove Gold Nuggets from the list of weapons. Apparently MacGyver ignores the Alien Blaster as a weapon :) and he could treat the Nuggets the same way.

Pus, dialogue error
When selling the bag of body parts the two options are “It's a deal” and “Fair enough”. Both wordings mean to agree, but the second option actually results in a no-deal and should say “Not fair!” or “Not enough.” http://www.filedropper.com/pussellbagerror & http://www.filedropper.com/slot307pussellbag (just in case, as it's only the first offer (I think) that has this issue. When repeated, the wording is fine).

Chuck loophole
Killing the children for Chuck is -25 (-10 & -15) karma for personal kills only. Companion kills don't count. Which is an oversight, imo. There are several instances where the player loses karma no matter who killed the civilian (casino fight, for example) and I feel it should apply here, too. I don't think the player should be allowed to avoid the karma loss by letting the companions carry out Chuck's dirty work. At least the -15 could always apply indifferent of who scored the kill.

Small point: When Chadwick is captured by the doctor's in Dead Quarter, he disappears after a while. He also disappears when I have an operation and leave the map. Shouldn't he disappear during the screen-fade (i.e. when talking to Falber after waking up)? At the moment there is no connection to Chadwick having been used as a donor for one's own operation (as he's still there after the OP) and it would be a nice touch (aka creepy) if that connection could be made more obvious, i.e. you go to sleep (Chadwick's there) you wake up (Chadwick's gone), and now we are together for ever :wink:.
Muttie wrote:Suzan, oh, Suzan
There is a slight issue with Suzan, as I can get the quest to lure her to Chadwick. Then I can convince Chadwick to show Francis his necklace (or kill him in the ring). And doing this does not cancel the option to lure Suzan (that's the error, as at this point it should probably trigger her reward dialogue (Geiger counter) when talking to her). In fact I can tell her to go see him and she ends up dead in Chadwick's home. No one reacts to it, and I can still hire her when talking to Wanda (ghost sex!? bit of a rip off, isn't it?). :) http://www.filedropper.com/slot286suzanghost (in this save the option is open (not reported to Francis yet) and Chadwick is already in jail).
Perhaps Suzan's reward dialogue could be triggered the moment Chadwick is dead or in jail. And not when reporting back to Francis (as I think it is atm?).
Addition: This also works with the Disgusting necklace. I can get the quest to lure Suzan, then steal the necklace, talk Suzan into visiting him, and then report to Francis with the necklace. Same outcome: Ghost sex.
So my first suggestion was ignorant :), well kind of. I think killing/arresting Chadwick, should cancel the option to talk Suzan into seeing a client and trigger her reward dialogue instead. But that won't cover the necklace option. Perhaps sending Suzan to Chadwick, could cancel the option to report to Francis (with the necklace). Instead Suzan is registered as “dead” (Wanda reacts “She left. I don't know where she is. I'm a bit worried...” etc.), and when reporting to Francis with the necklace, it causes Chadwick to run off (i.e. he despawns) and Francis comments: “You're too late, he killed Suzan and did a runner. No good bothering any further. And yes, it means I won't pay you. Get out of here.” and both quests are failed? (And Wanda could say her “Why did she do it...” etc. line). However, that would mean Chadwick would run without his necklace (?) and the player keeps it. Which isn't logical, but the next time the player sees Chadwick he'll be lamenting the loss of his necklace, so that would add up at least.

Chadwick murder conviction
I'm not sure if it's on purpose, but the solution to steal the necklace and handing it to Francis does not give +10 karma (male and female), as does the speech option and the fighting in the ring option (either by oneself or a companion). XP, caps and town rep is in all cases the same.

Chadwick necklace
Couldn't the necklace spawn the moment the “convict Chadwick” quest is active, rather than using either “proof” dialogue line. At the moment it is very easy to miss the necklace entirely. Why not spawn the necklace immediately? (Is it because “convicting” requires dialogue? Or to keep it a mystery until confirmed in dialogue?). Not sure. But you may take a look if “activating the quest” isn't the better trigger to spawn the necklace. At the moment it is really easy to miss. I think the trigger is “logical” as a first time player would not randomly check the inventory without confirming first that it actually is Chadwick (aka dialogue), but the very particular trigger makes it more hidden to a second time player, who has to figure it “when” to check the inventory, which is a bit weird.

Tyler Morrow quest
His quests seem to be cancelled when the kidnapping starts. He has two dialogue-replies when asking him about work & mentioning Sanchez, first, he says (too many people lurk around) and then (the boy has been kidnapped) and that never changes I think. However, the kidnapping quest does not cancel his quest-line but only the initial job offer :).
What I can do is: get the offer by Tyler Morrow, decline, start the kidnapping and then change my mind with Tyler Morrow. (His dialogue has two options: “work/mention Sanchez” which is declined, and the “I changed my mind” option, which still works, despite the kidnapping going on). And I can then follow both quest-lines simultaneously (which I really, really like!), until Carpenter dies (which cancels the kidnapping by turning Vex hostile).
This may be intended, as it works rather well (!), but it may also be an exploit. However, I would really like to make this the “standard way”. And rather than cancelling the “I changed my mind” option with Morrow, I would remove that Vex and Tyler cancel each other. The only cancel for the kidnapping could be Carpenter's death (i.e. reporting back to Morrow after the poison has been administered) or learning from Mimi about the kidnapping. I think that would make the kidnapping a nice addition to either path (good or evil), that may or may not occur. But being locked out of it by going with Tyler (which is already a decision between Tyler/Kevin or Nicol) feels too restricting. Like a third wheel. And having to replay the whole mod, for one quest only, feels wrong. So, please, consider to integrate the kidnapping into the “evil path”, rather than having two “evil play-throughs” with only one quest variation (Kidnapping instead Tyler).
I played through this “exploit scenario” in various ways and it seems to work fine. The only oddity is that the cops behave as if Carpenter is still alive (at the gate and inside the villa), but that is indifferent of the kidnapping (i.e. the last Morrow quest doesn't adjust the cops dialogue either). So in both cases the cops at the gate and inside the villa may slightly adjust to reflect that the sheriff is dead (or not here, as it's Tyler at the station now). (not a big deal though). And it should be noted that Morrow says “once I've kicked his wife and son out of the villa” which may need adjusting too, either to a neutral “clean the villa of his remaining family/house-hold/rabble” or a second version mentioning only his “widow”.
Regarding logic, there is the backstory that Morrow can't act because of the kidnapping. But I would say that all of Morrow's quest are carried out by a single outsider (the player), which takes care of the “I can't act” angle. However, you may consider to adjust Morrow's original reason to strengthen the point, like: “My hands are tied with the recent (activity around the villa/kidnapping) and I do need an outsider, someone no one suspects and who can't be linked to me.” etc. rather than saying “it's impossible”. And, last, some activities like bribing Jeffrey and the cook may reflect the kidnapping as well. Jeffrey: “You want me to do this, while all this shit is going on?! Well, it's your funeral. And it will cost you.” or Cook: “How can you think of something at a time like this. With poor little David kidnapped and all. [She becomes thoughtful.] Well, it may take his mind of things. And with all this evil business going on, I guess it may do him some good to be cheered up a little.” However, it's not a big deal. After all neither (Jeffrey or Cook) adjust to the kidnapping during the “gold nugget” quest either, they still agree to steal the nuggets or distract the sheriff regardless of the kidnapping of David. So they could also agree to swap the hip flask regardless.
Anyway, if you don't agree, and this is a bug/exploit, that must be fixed, you could also consider to do me the favour and forget I reported this loophole, and allow me to continue exploiting it in the future, thanks :).

Mutated Toe and healing
Getting healing from Falber while having a sixth toe is instant death. However, I can get healing from Yaotzin as a Mutant-Hunter while having six little piggies, and it has no consequence. Isn't that an oversight? As their healing should detect the toe, too, and should cause amputation, combat or instant death (which would be the easiest solution: “We can't have on of our own mutate and live. I hope you understand. I'm sure you do. [Strong hands grab both your arms and accompany you to the execution chamber.] We'll honour your sacrifice for the purity of mankind. [He (salutes/nods at) you.]”).
For convenience the HIV cure (blood sample and injection) may be excluded from this, and still work without detecting the toe. The argument could be that the HIV diagnosis does not include a whole physical, as treating wounds would. Anyway, it would make sense that a Mutant-Hunter with a mutation would need to hide, and visit other doctors.

Mutated Toe AG Bug?
By accident I found an old post saying that getting the toe amputated by Yaotzin is -5 AG. And that never happened to me. I have a character (http://www.filedropper.com/slot316toeandag) who gets -7 AG (from 8 to 1), and another (http://www.filedropper.com/slot317toeandag2) who gets -4 AG (from 6 to 2). No matter what I do it won't change. (I tried healing, removing radiation, curing HIV etc.). Is is possible that the issue is Gifted, and some mix up with “-5 AG but not below the minimum”? So the -4 AG is correct (the minimum for Gifted is 2), but the -7 bugs out (?).

Lystra Leaves: Timer
This took me some time to figure out. At first I thought I discovered a bug, but after several test runs, I believe it's actually good design. And after some more time, I realized there may be an exploit.
What happened was: I had Lystra and normally she leaves after (13 days (warning), 13 days (2nd warning), 13 days (leaves), Falcon has not been triggered). However, I wanted to grow a sixth toe and decided to rest in the desert to do so. Eventually two months had passed, and Lystra was still with me, which was confusing at first.
I speculated a lot and tested it, until I realized that her timer (of 26 days) won't start before the first warning (which needs to enter a map after 13 days have past). And only after the player has been warned once, will those 26 days start to tick down. Which is good design as it avoids to catch the player off-guard. And because of this I was able to keep her with me for 2 months, as I postponed the first warning by resting in the desert (i.e. I didn't enter a map that could trigger her warnings).
So that's good, and not a bug as I initially thought. It just confused me at first.
However, while testing, I also tested how the timer behaves when she leaves because my karma dropped below 50 or when I ask her to wait. In both cases the timer continues from the point I dropped her off. The only exception appears to be when she returns home. In that case the timer resets to 13 days. Which is a good idea, as 13 days allows to reach Corath (similar to the Falcon bonus, which also seems to add 13 days, I think). However, is it a good idea? As there is the exploit that I can ask her to wait shortly before she is about to leave, wait a week, pick her up in AQ again, and get another 13 days. (Note: I tested this with 1 day remaining on her timer, and when I picked her up she left within a day, but when I waited and picked her up in AQ it reset to 13 days. I also checked if it works twice in a row and it did). Knowing this makes losing her basically impossible. And perhaps, she shouldn't go back home when the quest for her brother is active but disappear instead (i.e. after the first warning, she'll wait for a week if removed from the party (karma or asked to wait), and if not picked up by then, she'll search for Sindian alone, instead going back home to AQ and wait there.) I think that makes sense. Not sure if it's fair or transparent though.
(P.S. remember the idea that the player may find her corpse in an encounter when she leaves like this, as I suggested above.)

Leaving companions in the desert
When I leave Mutt or Drools in the desert they disappear. However, when I leave Keri, Lystra or Gabriel on a desert map, they respawn on any other desert map I enter, until a week passes and they return home. Once it even happened that Lystra left me at the start of an encounter (hostile wanderers) as the timer to find her brother was up, and she fought with me (which should be normal, as companions (“usually” *see note) behave like that when told to wait, aka dropped out of the party). Then I left the map, and in the next encounter she spawned again and fought with me again. However, she was gone when I entered AQ, so I dismissed it as a minor glitch possibly caused by the combat after she left me. Otherwise, companions left in the desert would not spawn into encounters, but only on empty desert maps. Anyway, as Mutt & Drool disappear immediately, couldn't Keri, Lystra and Gabriel immediately return home, too, when left in the desert?
*i.e. they join combat as long as they are close by. However, Gabriel, if waiting at the casino, does not join me when I attack the mexicans, but neither does he attack me. Not sure how Keri and Lystra behave. But I assume they would be triggered by town hostility. At least Keri does. Not sure why Gabriel doesn't behave similarly? (both can be checked with Slot310, see above).

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Sat Nov 17, 2018 4:28 am

Muttie wrote:The only oddity is that the cops behave as if Carpenter is still alive (at the gate and inside the villa), but that is indifferent of the kidnapping (i.e. the last Morrow quest doesn't adjust the cops dialogue either).
This is wrong. Not sure what happened but I must have misread my notes. They said “cops inside the villa don't change”, and for some reason I assumed it meant both cases (derp), but it's really just the kidnapping in which the cops' dialogue doesn't adjust, i.e. it still says „Carpenter is mad“ etc.). During the Morrow quest itself the cops inside the villa react to Carpenter's death just fine. Only the speech option says „I have an appointment with the sheriff“, which may sound weird, but is still a legitimate reason to be there (i.e. it is the sheriff's villa and Morrow may show up there). The cops at the gate are nondescript, which makes sense, too, i.e. they don't have to tell every stranger what happened and just keep telling people to shove off.
Not a big deal, but I wanted to correct my error.

And something else that occurred to me. All the suggestions I made for fighting the cops at the CC pen (during the kidnapping), won't really work if the companions can just kill the cops (which is most likely to happen, as that's how the fight usually ends). (Note: companion kills don't cause hostility, which is weird, but often a relief). I mentioned that briefly in the beginning but didn't get into it more as I probably should have. Anyway, perhaps the Nanny should demand that the player “comes alone”. Or just leave it as it is, it's not a big deal, it's just that that scenario doesn't really play out (i.e. Keri and Gabriel just kill all the three cops with ease) and even without companions it shouldn't be difficult to kill them and the Nanny as long as making sure not to hit a bystander.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Fri Jan 04, 2019 9:32 pm

I updated my Fallout 2 version by replacing critter.dat and the issues I had before (i.e. Tommy in the cave not spawning & crash when entering Progema) are solved by that. So all it needs are the frms for the corpses (Tommy, Combat Armour, Power Armour and Robots (RL) (which are cut, too, believe it or not) (actually Interplay just deleted all frms ending on a BD to BN and RD to RM, without checking. At least, that would explain why FO1 did not cut the violent Overseer death animation, because that's a BA (lol).). Anyway, selling companions to Falber does still not work. I expected it would, but it didn't. So either I caused issues by replacing my critter.dat or the missing animations isn't the problem with selling companions.
When I sold Lystra there was no body. When I sold Gabriel the body would get stuck in the getting cut animation, as Keri did before. And Keri would cause the game to crash (00471bb99 at 00000001). When I reduce the violence setting it starts working. Well, kind of: Keri is now stuck in a “getting cut animation”, instead crashing the game (as reported before actually). So unless my version of FO2 is messed up, there may be a different issue. However, so far the new critter.dat I put in my FO2 game is working fine otherwise (tested repeatedly with all kind of mods, like RP or Last Hope).

Note: Resurrection does say that RP causes no issues, however, I did notice that the RP mod adjusts the master.dat ever so slightly when installed. It seems to adjust a few protos (see the manual installation which has a “batch_work” folder with a few critters pro files and a “master_dat_fix_up”). RP mod runs that automatically. It's probably nothing, it just surprised me, as the readme said that RP doesn't change the base game.

FRMs: I noted two things in Resurrection while going through the frms, first the “long hair” and “bald” characters have the O, P & Q animations (i.e. sword, saber & “scope rifle”). It's not important, but they are superfluous as Resurrection doesn't use those. And, secondly, HmWar2(...).(...) is missing all the death animations BD to BN (36 in total) and RD to RN (6 in total). Those missing frms should be in the Appearance mod (HMR00S02), as I believe that's where the bald tribe/warrior is originally from.

Btw, the oddity that companion kills don't trigger hostility really is an engine error, i.e. it's in Fallout 1, too. There, I can have Ian wipe Shady Sands and no one cares.
(P.S. I almost feel bad for some of the reports I have posted in the past. Some of them struggled as much with my ignorance, and trying to put that into words, as they did report problems.)
“struggling to put ignorance into words” lol, like every conversation, ever. ;)
Anyway, they could have been better. I recently had to reread a couple of them and it took me a while to understand the point. Usually a bad sign.

User avatar
Posts: 145
Joined: Tue Dec 26, 2017 10:42 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by Muttie » Sun Jan 06, 2019 12:30 am

Muttie wrote:the “long hair” and “bald” characters have the O, P & Q animations (i.e. sword, saber & “scope rifle”).
Sorry, I didn't pay much attention to this point but should have added which those are anyway.

Those are: HMLTH3(...).(...), HMMAX3(...).(...) and HMMET2(...).(...)

Posts: 122
Joined: Fri Oct 04, 2013 10:40 am

Re: BUGS Swarming our position! Request suppressing fire

Post by valcik » Sun Jan 06, 2019 7:04 pm

Muttie wrote:.. the RP mod adjusts the master.dat ever so slightly when installed. It seems to adjust a few protos ..
These are stage 6 prototype files for Vic and Cassidy AFAIK.

User avatar
Posts: 73
Joined: Fri Jul 15, 2016 5:40 pm

Re: BUGS Swarming our position! Request suppressing fire

Post by NovaRain » Mon Jan 07, 2019 7:06 am

valcik wrote:
Muttie wrote:.. the RP mod adjusts the master.dat ever so slightly when installed. It seems to adjust a few protos ..
These are stage 6 prototype files for Vic and Cassidy AFAIK.
The protos added from RP are base protos for new EPA party members and bug fixes for Skynet, Cassidy, and Lenny.

Posts: 122
Joined: Fri Oct 04, 2013 10:40 am

Re: BUGS Swarming our position! Request suppressing fire

Post by valcik » Mon Jan 07, 2019 11:58 am

These changes doesn't affect Resurrection anyway.

Post Reply